Jump to content

GTN Com Radio Info


Recommended Posts

There have been some threads around the web about issues with the receivers in the Xi series GTN GPS/NAV/COM units.   It has been traced to the squelch settings.

Garmin just released updated software for the units (20.42) that increases the range that the Carrier Squelch can be adjusted to.

A couple of guys over on BT, who are professionals in radios have tested things and come up with some recommended settings.

If you do not have 20.42, you can still help your receive performance.

For the Noise Squelch, for all software versions, set it to 0.  The default is 57 and a lot of people have missed a lot of radio calls with this setting.

If you are updates to 20.42, set the Carrier Squelch to -25.   For earlier version, set this to 0 also.

They feel that with 20.42 and these settings, the Xi receiver is one of the best available on the aviation market.

  • Like 4
Link to comment
Share on other sites

Really makes you wonder about the QC and just basic testing if we had to go from 57 to -25

I love my GTN, but it was a pain figuring out you had to go to 0.  From my Tech experience, I could see the Avionics guy just questioning why he kept moving it down so far to get it to work.

Link to comment
Share on other sites

On 6/11/2024 at 11:55 AM, PeteMc said:

Really makes you wonder about the QC and just basic testing if we had to go from 57 to -25

I love my GTN, but it was a pain figuring out you had to go to 0.  From my Tech experience, I could see the Avionics guy just questioning why he kept moving it down so far to get it to work.

Two squelches:

Noise squelch was factory set to 57 but works best at 0 to 10.

Carrier squelch adjustment used to bottom out at 0 which is the factory setting. With the new software it can be set as low as -100. For most airplanes, 0 is fine. If your airplane is noisy RF-wise, a lower setting may help. The Beechtalk guys find -25 to be a good number for most applications.

I long ago figured out to set the noise squelch to 0 and mine has been working fine and compares in sensitivity to the #2 which is a GNC 255. 

I didn't mess with the antenna or original RG-58 coax when I had the GTN 650Xi installed. I know that RG-400 is all the rage, and it is better coax being double shielded and slightly lower loss. But, I wasn't having any problems that required better shielding and at com frequencies for the short runs in the airplane, the loss difference is negligible. I'm a "don't mess with it if it's working" kind of guy :).

 

 

Link to comment
Share on other sites

I don't understand anything you guys have said, but after my 650 Xi was installed, I had significant problems with my Coms. Then they were fixed - maybe doing whatever you said above. I do have one remaining problem: when I enter Zurich or Geneva airspace, the first frequency is always broken. Both of those frequencies are higher ones, 130 or higher. Can these problems have anything to do with the frequency, or do I have a separate problem?

Link to comment
Share on other sites

1 hour ago, Sue Bon said:

I don't understand anything you guys have said, but after my 650 Xi was installed, I had significant problems with my Coms. Then they were fixed - maybe doing whatever you said above. I do have one remaining problem: when I enter Zurich or Geneva airspace, the first frequency is always broken. Both of those frequencies are higher ones, 130 or higher. Can these problems have anything to do with the frequency, or do I have a separate problem?

I am not a radio guy but, as @pinecone noted above, "Garmin just released updated software (20.42) that increases the range that the Carrier Squelch can be adjusted to" so it sounds like two things need to happen to take advantage of the change:
1. install new software
2. have an installer or maintainer who works on radios try some different settings to take advantage of the new software.

  • Like 1
Link to comment
Share on other sites

7 hours ago, Sue Bon said:

Can these problems have anything to do with the frequency, or do I have a separate problem?

My *guess* is it is a combination.  I definitely talk to your Avionics Shop and ask them if this new Software and some additional tweaks will help.   

And when you say "broken" is it receiving, transmitting or both?  If receiving, will hitting the Squelch help you hear them?  If so, then you may just need to make sure your Noise Squelch is down in the 0 -10 range.  It took a while before they really lowered my that much since the thought it was such a big change from the Garmin setting.  Bottom line is to check with your shop or A Shop that is familiar with this local issue.

 

Edited by PeteMc
  • Like 1
Link to comment
Share on other sites

7 hours ago, Sue Bon said:

I don't understand anything you guys have said, but after my 650 Xi was installed, I had significant problems with my Coms. Then they were fixed - maybe doing whatever you said above. I do have one remaining problem: when I enter Zurich or Geneva airspace, the first frequency is always broken. Both of those frequencies are higher ones, 130 or higher. Can these problems have anything to do with the frequency, or do I have a separate problem?

There might be some intereference at those frequencies that don't affect others.    Sometimes the interference is local to the airspace and sometimes it comes from something on your airplane, or even in the same radio receiver that has the problem.   If those frequencies work okay elsewhere then it may just be something in that airspace.   Depending on a lot of things, it could affect your airplane more than others.

That's just one possibility.

 

  • Thanks 1
Link to comment
Share on other sites

13 minutes ago, PeteMc said:

And when you say "broken" is it receiving, transmitting or both? 

Both. There is probably something happening with my plane, as @EricJ mentioned. I had big problems before the panel upgrade. I thought taking everything out and putting it back in new would solve it. At least now it's just those frequencies, in that airspace - that I know of. That's the only time I hear it, and they are the only ones that say "read you broken". Maybe the software update will help. Let's hope. 

  • Like 1
Link to comment
Share on other sites

Easy. If you have a GTN-xxxXi radio, get the 20.42 update installed at a dealer.

Tell them to set the Noise Squelch to 0 and the Carrier Squelch to -25.

Neither you nor they need to know what it means. :D :D

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.