Jump to content

Alternator issue


Recommended Posts

 

So I'm on month 11 of being a Bravo owner and getting a bit frustrated.  I have now replaced the alternator which was all chewed up and caused 2 in flight belt failures.  An issue i had prior and that is still occuring is this.  The alternator will kick offline when the landing or taxi lights are turned on, and would need a subsequent reset by turning ALT switch off then back on. Don't suppose anyone else has experienced this one before?

  • Like 1
Link to comment
Share on other sites

Sorry to hear about this. I’m no expert but I would think your voltage regulator would be part of the problem. I guess I thought you had fixed the belt part. Or maybe I missed that part of the thread.

Link to comment
Share on other sites

1 hour ago, BravoWhiskey said:

Alternator had siexed up twice causing one belt to break and the next one to flip over.  Finally realized the alternator was bad so that was replaced.  

Any other symptoms?  Electrical noise in headsets?  What is the amp meter indicating, normally and when you add loads?  Would look at things like the integrity of grounds, from regulator to ground, engine to airframe ground, battery connections. Also, alignment of the alternator pulley….but that doesn’t quite explain the drop outs…

Link to comment
Share on other sites

2 hours ago, BravoWhiskey said:

Alternator had siexed up twice causing one belt to break and the next one to flip over.  Finally realized the alternator was bad so that was replaced.  

Are both of your alternators the same model or was one upgraded to a Plane Power?

Link to comment
Share on other sites

I'll do another run and check the different voltage drops and resets after i turn alt switch off then back on.  Somthing somewhere is tripping which is common with inrush current, right? But then the current seems to be stable after i turn the alt switch off then back on.

Link to comment
Share on other sites

On 11/20/2021 at 8:25 PM, BravoWhiskey said:

 

So I'm on month 11 of being a Bravo owner and getting a bit frustrated.  I have now replaced the alternator which was all chewed up and caused 2 in flight belt failures.  An issue i had prior and that is still occuring is this.  The alternator will kick offline when the landing or taxi lights are turned on, and would need a subsequent reset by turning ALT switch off then back on. Don't suppose anyone else has experienced this one before?

It's too early to get frustrated, keep the faith and consider yourself lucky you are only chasing down alternator / regulator issues...It took me two years to square away all of the missed squawks on my Bravo.  When I fantasize about another airplane, I remind myself what it took to get here and I throw money at the panel upgrades instead.

  • Like 2
Link to comment
Share on other sites

On 11/21/2021 at 11:05 AM, BravoWhiskey said:

I'll do another run and check the different voltage drops and resets after i turn alt switch off then back on.  Somthing somewhere is tripping which is common with inrush current, right? But then the current seems to be stable after i turn the alt switch off then back on.

Some older posts to look over in the Bravo section:

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.