Recommended Posts

After researching and reading about this on an older thread, I had to re-ask this question. The boost pump on my ‘82 K has a very slow, but noticeable drip. Just noted over the past week or so. Pulled the cover and panels to look everything over, and filmed this video. When operating the boost, the drip increases noticeable. In an old thread, someone had mentioned that this is ‘normal’ or ‘expected’ but I find that hard to believe. Thinking that I would need to follow advice in the other thread, and send out for overhaul, but want to hear some confirmation!

Thanks to all!

 

Share this post


Link to post
Share on other sites

*Members that donate $10 or more do not see advertisements*

Time for new seals...

Something I believe I had my mechanic take care of a few years ago...

Best regards,

-a-

Share this post


Link to post
Share on other sites

FTR, fuel leaking anywhere is unacceptable; except for minor wing tank seeps.


Sent from my iPhone using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites

Time to send the pump to Aeromotors LLC in Wisconsin.

Clarence

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.