Sign in to follow this  
Larry

Landing Gear Horn

Recommended Posts

I have a '90 J and am having a problem with the gear horn.  The horn will sound for about 1 second, then stop.  The throttle microswitch has been cleaned with contact cleaner and hits the detent at the correct MP.  The Sonolert was replaced, but still the same 1 second warning.  Any ideas?

Larry

Share this post


Link to post
Share on other sites

*Members that donate $10 or more do not see advertisements*

Check the electrical connection and voltage at the Sonalert and make sure it's wired properly with respect to polarity. Hopefully it's not the voltage that is dropping off.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

It is such a simple system...

switch, battery, and sonalert...

A volt meter will answer a lot of questions...

Wiring diagram is in the POH... in many of our planes....

PP Thinking out loud...not a mechanic.

Best regards,

-a-

Share this post


Link to post
Share on other sites

I think you have a bad buzzer. I added a Voice Alert gear warning and very happy with it. When turning base at low speed the gear warning buzzer may be mistaken with the stall warning. The Voice Alert clearly identifies the source of the warning. Keeps you from having a belly rub. Check: http://www.aircraftspruce.com/catalog/avpages/voicegearalert.php?clickkey=46870

José

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this